Jump to content

Welcome to AnimePassion
Register now to gain access to all of our features. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more. If you already have an account, login here - otherwise create an account for free today!
Photo

CCCP vs CoreAVC vs MadVR


  • This topic is locked This topic is locked
37 replies to this topic

#1
WaveZero

WaveZero

    LOLing

  • VIP
  • 704 posts
  • 0 thanks
  • Local time: 07:02 AM
  • LocationAustralia
Hey guys! I'm doing a comparison for you guys on these three popular decoders for the H.264 codec. I have all three decoders installed on my computer, so I thought I might as well test it and see which one is the best.

From what I noticed CCCP (FFDShow), CoreAVC and MadVR are almost same in terms of quality, if you are outputting the file at its native video file resolution. As seen here:

Forge's Hi10P 720p Heaven's Lost Property - CCCP vs MadVR:
http://screenshotcom...mparison/101595

Forge's Hi10P 720p Heaven's Lost Property - CCCP vs CoreAVC:
http://screenshotcom...mparison/101598

Forge's Hi10P 720p Heaven's Lost Property - CoreAVC vs MadVR:
http://screenshotcom...mparison/101601

For the 480p to 720p upscale you can notice a slight difference with MadVR (more sharper) and while CCCP and CoreAVC looks the same.

NMH's 480p Durarara!! - CCCP vs MadVR:
http://screenshotcom...mparison/101602

NMH's 480p Durarara!! - CCCP vs CoreAVC:
http://screenshotcom...mparison/101603

NMH's 480p Durarara!! - CoreAVC vs MadVR:
http://screenshotcom...mparison/101604

Wow I had a lot of issues uploading it to screenshot comparison >.> I hope you guys find this useful! Hopefully this will help you guys decide which decoder is the best to use. If you ask me, it doesn't really matter. It's all up to personal taste, since the difference between them is quite small in terms of quality. I'm sticking with CoreAVC for now (since it is a lot faster than FFDshow), but will use MadVR when upscaling. I'm keeping CCCP as well, because when I installed MadVR I didn't install audio decoders or any of those other stuff the MadVR needs since CCCP already offers them and I had it installed long before MadVR or CoreAVC.

Jeez it's like 3am here >.>

Posted Image


#2
Cman21

Cman21

    /)*(\ ^_^

  • Administrators
  • 2,432 posts
  • 255 thanks
  • Local time: 06:02 PM
why code the links? you only must code links to file hosts.

#3
13ack.Stab

13ack.Stab

    Assassin

  • Administrators
  • 1,719 posts
  • 16 thanks
  • Local time: 06:02 PM
  • LocationMichigan, USA
Out of curiosity, did you check to see if the codec packs weren't interfering with one another? You did say you had them all installed at once. :P

Posted Image


#4
pinny

pinny

    Cardcaptor

  • VIP
  • 333 posts
  • 0 thanks
  • Local time: 12:02 AM
You can configure MadVR to use different sharpening filters, which ones did you use in your screenshots?

Also you're comparing Video renderers to Video decoders?

Or did you solely compare CCCP's ffdshow video decoder to MadVR's video decoder and CoreAVC video decoder?
Since I don't see how you can compare MadVR's video renderer to CCCP or CoreAVC which neither are video renderers. I suppose you're comparing MadVR to EVR?

Posted Image


#5
WaveZero

WaveZero

    LOLing

  • VIP
  • 704 posts
  • 0 thanks
  • Local time: 07:02 AM
  • LocationAustralia

why code the links? you only must code links to file hosts.

Lol sorry my bad, I was a bit tired, I suppose we don't need it.

Out of curiosity, did you check to see if the codec packs weren't interfering with one another? You did say you had them all installed at once. :P

Yep =), and none of them were interfering, I just unregistered it through the settings or used MPC-HC to configure which decoder to use. I used the FFDShow Audio decoder for each one, but that does nothing to the image quality, so it's all good =).

You can configure MadVR to use different sharpening filters, which ones did you use in your screenshots?

Also you're comparing Video renderers to Video decoders?

Or did you solely compare CCCP's ffdshow video decoder to MadVR's video decoder and CoreAVC video decoder?
Since I don't see how you can compare MadVR's video renderer to CCCP or CoreAVC which neither are video renderers. I suppose you're comparing MadVR to EVR?

I didn't configure anything, these are default installs with a few settings changed to allow me to take images. I kinda rushed this, I suppose I could try differerent sharpening filters (haven't check it out yet). I'm comparing video decoders not renders or wait I'm sure these are decoders, aren't they? Just woke up so getting kinda confused. And yes you're correct I'm comparing MadVR with EVR custom pres, that's what it says on MPC-HC.

Posted Image


#6
Pra7ul

Pra7ul

    King of Pirates

  • VIP
  • 380 posts
  • 0 thanks
  • Local time: 04:32 AM
  • LocationWindmill Village
When i select Playback > Output > madVR

only audio get played and on video screen all i can see is black screen....

i'm using K-lite codec pack.. with default settings [currently playing videos on EVR Custom Pres**]

Pra7ul.jpg
Anime-Planet.com - anime | manga | reviews

 

iqpq.png


#7
Zachimillius

Zachimillius

    エッチ様

  • VIP
  • 2,282 posts
  • 0 thanks
  • Local time: 10:02 AM
  • LocationSydney, Australia
Uninstall all your players and codecs, then you should just follow the MPC-HC and madVR guide on our forums here

Posted Image


#8
Pra7ul

Pra7ul

    King of Pirates

  • VIP
  • 380 posts
  • 0 thanks
  • Local time: 04:32 AM
  • LocationWindmill Village
^
^
^I Tried that

At first i tried this guide, so it worked perfectly fine for the first time, then i reinstalled my OS for some reason, after that first time i am constantly getting the problem mentioned above, no matter the changes in settings i do.

so i switched on K-Lite codec thinking it will do the trick but i am getting same problem as i was when i was on CCCP.

Pra7ul.jpg
Anime-Planet.com - anime | manga | reviews

 

iqpq.png


#9
13ack.Stab

13ack.Stab

    Assassin

  • Administrators
  • 1,719 posts
  • 16 thanks
  • Local time: 06:02 PM
  • LocationMichigan, USA

i switched on K-Lite codec thinking it will do the trick but i am getting same problem as i was when i was on CCCP.


Don't use K-Lite or CCCP. Remove all your codecs and whatnot, then reboot. Then follow the MPC-HC + madVR guide Zach linked to manually install haali, LAV audio & video, and MPC-HC.

Posted Image


#10
Pra7ul

Pra7ul

    King of Pirates

  • VIP
  • 380 posts
  • 0 thanks
  • Local time: 04:32 AM
  • LocationWindmill Village

Don't use K-Lite or CCCP. Remove all your codecs and whatnot, then reboot. Then follow the MPC-HC + madVR guide Zach linked to manually install haali, LAV audio & video, and MPC-HC.



i'll try it now...

Pra7ul.jpg
Anime-Planet.com - anime | manga | reviews

 

iqpq.png


#11
Pra7ul

Pra7ul

    King of Pirates

  • VIP
  • 380 posts
  • 0 thanks
  • Local time: 04:32 AM
  • LocationWindmill Village
Still getting problem i after installing latest MPC-HC and all.

Posted Image



#12
13ack.Stab

13ack.Stab

    Assassin

  • Administrators
  • 1,719 posts
  • 16 thanks
  • Local time: 06:02 PM
  • LocationMichigan, USA
Do you have madVR installed? If so, does it run when you play videos (check your filters and look for the madVR icon in your tray).

That madVR screenshot looks correct, though I like to leave RealMedia & QuickTime to System Default.

Posted Image


#13
Pra7ul

Pra7ul

    King of Pirates

  • VIP
  • 380 posts
  • 0 thanks
  • Local time: 04:32 AM
  • LocationWindmill Village

Do you have madVR installed? If so, does it run when you play videos (check your filters and look for the madVR icon in your tray).

its installed and tray icon is there.. [i even did the madVR setting]

Pra7ul.jpg
Anime-Planet.com - anime | manga | reviews

 

iqpq.png


#14
13ack.Stab

13ack.Stab

    Assassin

  • Administrators
  • 1,719 posts
  • 16 thanks
  • Local time: 06:02 PM
  • LocationMichigan, USA

its installed and tray icon is there.. [i even did the madVR setting]

Interesting. May I see your Internal and External Filters settings?

Posted Image


#15
Pra7ul

Pra7ul

    King of Pirates

  • VIP
  • 380 posts
  • 0 thanks
  • Local time: 04:32 AM
  • LocationWindmill Village

Posted Image






Now I cant play both AUDIO+VIDEO
when i try playing it MPC-HC starts with a Pause and dose not play.

Pra7ul.jpg
Anime-Planet.com - anime | manga | reviews

 

iqpq.png


#16
13ack.Stab

13ack.Stab

    Assassin

  • Administrators
  • 1,719 posts
  • 16 thanks
  • Local time: 06:02 PM
  • LocationMichigan, USA
One last thing. :)

Can you show me the madVR's general settings (under rendering), please?

Posted Image


#17
Pra7ul

Pra7ul

    King of Pirates

  • VIP
  • 380 posts
  • 0 thanks
  • Local time: 04:32 AM
  • LocationWindmill Village
madVR setting :

Posted Image


one more thing which happens only with madVR [snap of taskmanager] :

Posted Image

without ending process mpc-hc wont open.

Pra7ul.jpg
Anime-Planet.com - anime | manga | reviews

 

iqpq.png


#18
13ack.Stab

13ack.Stab

    Assassin

  • Administrators
  • 1,719 posts
  • 16 thanks
  • Local time: 06:02 PM
  • LocationMichigan, USA
You can't play audio or video now? Strange. I'm going to be honest here -- I'm not sure why you're having such extensive issues with madVR and MPC-HC. I've checked the obvious stuff, and it's hard to debug anything else the way we have been.

Do you want me to try and fix things for you remotely (i.e. with TeamViewer)? If so, shoot me a PM.

Otherwise, the only thing I can suggest is to check for conflicts with your installations, and to ensure that your drivers are up to date.

As an aside, you've reminded me that I need to update the guide a bit. Thanks! ;)

Posted Image


#19
Pra7ul

Pra7ul

    King of Pirates

  • VIP
  • 380 posts
  • 0 thanks
  • Local time: 04:32 AM
  • LocationWindmill Village

Do you want me to try and fix things for you remotely (i.e. with TeamViewer)? If so, shoot me a PM.

if it's not too much trouble for you .....

Otherwise, the only thing I can suggest is to check for conflicts with your installations, and to ensure that your drivers are up to date.

I always keep my drivers and every software up to date [and so did i correctly followed the installation]

As an aside, you've reminded me that I need to update the guide a bit. Thanks! ;)

download links were of bit older version..

Pra7ul.jpg
Anime-Planet.com - anime | manga | reviews

 

iqpq.png


#20
13ack.Stab

13ack.Stab

    Assassin

  • Administrators
  • 1,719 posts
  • 16 thanks
  • Local time: 06:02 PM
  • LocationMichigan, USA
Mission failed, we couldn't get things to work.

Sorry, Pra7ul!

Posted Image



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users